const regex = /^(0?[1-9]|1[012])\/(0?[1-9]|[12]\d|3[01])\/[12]\d{3} ([01]\d|2[0-3])\:[0-5]\d\:[0-5]\d$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0?[1-9]|1[012])\\\/(0?[1-9]|[12]\\d|3[01])\\\/[12]\\d{3} ([01]\\d|2[0-3])\\:[0-5]\\d\\:[0-5]\\d$', '')
const str = `
2/2/2013 00:00:00
2/2/2013 12:30:20`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}