$re = '/(\d{3})-(\d{8})|(\d{4})-(\d{7,8})/';
$str = '021-54749110
0531-88881234
0635-8238080';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);