re = /(\d{3})-(\d{8})|(\d{4})-(\d{7,8})/
str = '021-54749110
0531-88881234
0635-8238080'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end