// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{3})-(\d{8})|(\d{4})-(\d{7,8})").unwrap();
let string = "021-54749110
0531-88881234
0635-8238080";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}