import re
regex = re.compile(r"(\d{3})-(\d{8})|(\d{4})-(\d{7,8})")
test_str = ("021-54749110 \n"
"0531-88881234\n"
"0635-8238080")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")