#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(\d{3}) - (\d{8}) #region code, -, phone number" & @CRLF & _
"| #alternative" & @CRLF & _
"(\d{4}) - (\d{7,8})#region code, -, phone number"
Local $sString = "021-54749110 " & @CRLF & _
"0531-88881234" & @CRLF & _
"0635-8238080"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")