package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)(\d{3}) - (\d{8}) #region code, -, phone number
| #alternative
(\d{4}) - (\d{7,8})#region code, -, phone number`)
var str = `021-54749110
0531-88881234
0635-8238080`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}