const regex = /(\d{3}) - (\d{8}) #region code, -, phone number
| #alternative
(\d{4}) - (\d{7,8})#region code, -, phone number/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3}) - (\\d{8}) #region code, -, phone number
| #alternative
(\\d{4}) - (\\d{7,8})#region code, -, phone number', 'g')
const str = `021-54749110
0531-88881234
0635-8238080`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}