package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[[:xdigit:]]{2}(?:[^[:xdigit:]]?[[:xdigit:]]{2}){5}\b`)
var str = `This regular expression matches whatever looks like a MAC addresses.
01:b7:78:Fe:4D:B8
01b7.78Fe.4DB8
01b778-Fe4DB8
01b778Fe4DB8
01#b778Fe;4D!B8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}