const regex = /\b[[:xdigit:]]{2}(?:[^[:xdigit:]]?[[:xdigit:]]{2}){5}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[[:xdigit:]]{2}(?:[^[:xdigit:]]?[[:xdigit:]]{2}){5}\\b', 'g')
const str = `This regular expression matches whatever looks like a MAC addresses.
01:b7:78:Fe:4D:B8
01b7.78Fe.4DB8
01b778-Fe4DB8
01b778Fe4DB8
01#b778Fe;4D!B8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}