import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[[:xdigit:]]{2}(?:[^[:xdigit:]]?[[:xdigit:]]{2}){5}\\b";
final String string = "This regular expression matches whatever looks like a MAC addresses.\n\n"
+ "01:b7:78:Fe:4D:B8\n"
+ "01b7.78Fe.4DB8\n"
+ "01b778-Fe4DB8\n"
+ "01b778Fe4DB8\n"
+ "01#b778Fe;4D!B8";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}