re = /\b[[:xdigit:]]{2}(?:[^[:xdigit:]]?[[:xdigit:]]{2}){5}\b/
str = 'This regular expression matches whatever looks like a MAC addresses.
01:b7:78:Fe:4D:B8
01b7.78Fe.4DB8
01b778-Fe4DB8
01b778Fe4DB8
01#b778Fe;4D!B8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end