using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|^(\w+)|\w+\sPTR\s\[rip\+[^\],]+\](?=.*#\s0x0*([a-f0-9]+))|(\w+\sPTR\s\[[^\],]+\])|(?<!#\s)0x([a-f0-9]*)|(?<!#\s)(?|,(\w+)|(\w+),))";
string input = @"movss xmm0,DWORD PTR [rip+0xd4],0x0000000000400978,eax,0x0,DWORD PTR [rbp-0x4] # 0x0000000000400c08
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}