const regex = /(?|^(\w+)|\w+\sPTR\s\[rip\+[^\],]+\](?=.*#\s0x0*([a-f0-9]+))|(\w+\sPTR\s\[[^\],]+\])|(?<!#\s)0x([a-f0-9]*)|(?<!#\s)(?|,(\w+)|(\w+),))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|^(\\w+)|\\w+\\sPTR\\s\\[rip\\+[^\\],]+\\](?=.*#\\s0x0*([a-f0-9]+))|(\\w+\\sPTR\\s\\[[^\\],]+\\])|(?<!#\\s)0x([a-f0-9]*)|(?<!#\\s)(?|,(\\w+)|(\\w+),))', 'g')
const str = `movss xmm0,DWORD PTR [rip+0xd4],0x0000000000400978,eax,0x0,DWORD PTR [rbp-0x4] # 0x0000000000400c08
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}