import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|^(\\w+)|\\w+\\sPTR\\s\\[rip\\+[^\\],]+\\](?=.*#\\s0x0*([a-f0-9]+))|(\\w+\\sPTR\\s\\[[^\\],]+\\])|(?<!#\\s)0x([a-f0-9]*)|(?<!#\\s)(?|,(\\w+)|(\\w+),))";
final String string = "movss xmm0,DWORD PTR [rip+0xd4],0x0000000000400978,eax,0x0,DWORD PTR [rbp-0x4] # 0x0000000000400c08\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}