re = /(?|^(\w+)|\w+\sPTR\s\[rip\+[^\],]+\](?=.*#\s0x0*([a-f0-9]+))|(\w+\sPTR\s\[[^\],]+\])|(?<!#\s)0x([a-f0-9]*)|(?<!#\s)(?|,(\w+)|(\w+),))/
str = 'movss xmm0,DWORD PTR [rip+0xd4],0x0000000000400978,eax,0x0,DWORD PTR [rbp-0x4] # 0x0000000000400c08
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end