#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\-(moz|o|webkit|ms|khtml)\-(?!font-smoothing|osx|print).+?;"
Local $sString = ".box {" & @CRLF & _
" float: right;" & @CRLF & _
" padding: 0.8em 0.8em 0.4em 0.8em;" & @CRLF & _
" background-color: #f0f0f0; " & @CRLF & _
" border-radius: 0.4em; " & @CRLF & _
" -moz-border-radius: 0.4em; " & @CRLF & _
" -o-border-radius: 0.4em; " & @CRLF & _
" -webkit-border-radius: 0.4em;" & @CRLF & _
" -ms-border-radius: 0.4em;" & @CRLF & _
" -webkit-font-smoothing: antialiased;" & @CRLF & _
" -moz-osx-font-smoothing: grayscale;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")