using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\-(moz|o|webkit|ms|khtml)\-(?!font-smoothing|osx|print).+?;";
string input = @".box {
float: right;
padding: 0.8em 0.8em 0.4em 0.8em;
background-color: #f0f0f0;
border-radius: 0.4em;
-moz-border-radius: 0.4em;
-o-border-radius: 0.4em;
-webkit-border-radius: 0.4em;
-ms-border-radius: 0.4em;
-webkit-font-smoothing: antialiased;
-moz-osx-font-smoothing: grayscale;
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}