import Foundation
let pattern = #"\-(moz|o|webkit|ms|khtml)\-(?!font-smoothing|osx|print).+?;"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
.box {
float: right;
padding: 0.8em 0.8em 0.4em 0.8em;
background-color: #f0f0f0;
border-radius: 0.4em;
-moz-border-radius: 0.4em;
-o-border-radius: 0.4em;
-webkit-border-radius: 0.4em;
-ms-border-radius: 0.4em;
-webkit-font-smoothing: antialiased;
-moz-osx-font-smoothing: grayscale;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)