// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)query (?P<function_name>\S*)\s+?(\((?P<function_args>.+?)\))?\s+?{").unwrap();
let string = "query get_telemetry (name: String, start_time: String, end_time: String) {
parameters:satelliteOperatorInteractionParameters(name: $name) {
edges {
node {
name
path
states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {
edges {
node {
timestamp
calibrated_value:calibratedValue
}
}
}
}
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}