const regex = /(?>[^;']|(?:''|(?>'(?:[^']|\\')*[^\\]')))+;/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>[^;\']|(?:\'\'|(?>\'(?:[^\']|\\\\\')*[^\\\\]\')))+;', 'gi')
const str = `BEGIN;INSERT INTO TABLE_A (a, b, c) VALUES('42', '12', '\\'ab\\'c; DEF');INSERT INTO TABLE_B (d, e, f) VALUES('42', '43', 'XYZ ;uvw');COMMIT;select 'ds; ds\\';da';`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}