re = /(?>[^;']|(?:''|(?>'(?:[^']|\\')*[^\\]')))+;/ix
str = 'BEGIN;INSERT INTO TABLE_A (a, b, c) VALUES(\'42\', \'12\', \'\\\'ab\\\'c; DEF\');INSERT INTO TABLE_B (d, e, f) VALUES(\'42\', \'43\', \'XYZ ;uvw\');COMMIT;select \'ds; ds\\\';da\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end