use strict;
my $str = 'BEGIN;INSERT INTO TABLE_A (a, b, c) VALUES(\'42\', \'12\', \'\\\'ab\\\'c; DEF\');INSERT INTO TABLE_B (d, e, f) VALUES(\'42\', \'43\', \'XYZ ;uvw\');COMMIT;select \'ds; ds\\\';da\';';
my $regex = qr/(?>[^;']|(?:''|(?>'(?:[^']|\\')*[^\\]')))+;/ixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}