$re = '/(?>[^;\']|(?:\'\'|(?>\'(?:[^\']|\\\\\')*[^\\\\]\')))+;/ixU';
$str = 'BEGIN;INSERT INTO TABLE_A (a, b, c) VALUES(\'42\', \'12\', \'\\\'ab\\\'c; DEF\');INSERT INTO TABLE_B (d, e, f) VALUES(\'42\', \'43\', \'XYZ ;uvw\');COMMIT;select \'ds; ds\\\';da\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);