using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b";
string input = @"10 29 39 300 33992 373
323
1 2 3456 6678
4345
33333 8 99 40 438 440 100 120 244 245 255 256 99 2000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}