const regex = /\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b', 'gm')
const str = `10 29 39 300 33992 373
323
1 2 3456 6678
4345
33333 8 99 40 438 440 100 120 244 245 255 256 99 2000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}