$re = '/\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b/m';
$str = '10 29 39 300 33992 373
323
1 2 3456 6678
4345
33333 8 99 40 438 440 100 120 244 245 255 256 99 2000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);