// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b").unwrap();
let string = "10 29 39 300 33992 373
323
1 2 3456 6678
4345
33333 8 99 40 438 440 100 120 244 245 255 256 99 2000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}