# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\r\n|\n|\,|\')+(?=.*")/ /gms;t' <<< "\"1111's SW,
2nd Street Plantation,
FL 33324\""