using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\r\n|\n|\,|\')+(?=.*"")";
string substitution = @" ";
string input = @"""1111's SW,
2nd Street Plantation,
FL 33324""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}