import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\r\\n|\\n|\\,|\\')+(?=.*\")";
final String string = "\"1111's SW,\n"
+ "2nd Street Plantation,\n"
+ "FL 33324\"";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}