package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)%(?'flag'[-0+ #]{0,3})(?'minwidth'[0-9]*)(?'comma'\.)?(?'precision'(?('comma')[0-9]*))(?'length'[hlqLjzZt]|ll|hh)?(?'type'[dscuobS%nfeEgGaACDiIOUpXx]{1})`)
var str = `Hello World! My name is %s and I have %+05.3f€`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}