const regex = /%(?'flag'[-0+ #]{0,3})(?'minwidth'[0-9]*)(?'comma'\.)?(?'precision'(?('comma')[0-9]*))(?'length'[hlqLjzZt]|ll|hh)?(?'type'[dscuobS%nfeEgGaACDiIOUpXx]{1})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%(?\'flag\'[-0+ #]{0,3})(?\'minwidth\'[0-9]*)(?\'comma\'\\.)?(?\'precision\'(?(\'comma\')[0-9]*))(?\'length\'[hlqLjzZt]|ll|hh)?(?\'type\'[dscuobS%nfeEgGaACDiIOUpXx]{1})', 'gm')
const str = `Hello World! My name is %s and I have %+05.3f€`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}