re = /%(?'flag'[-0+ #]{0,3})(?'minwidth'[0-9]*)(?'comma'\.)?(?'precision'(?('comma')[0-9]*))(?'length'[hlqLjzZt]|ll|hh)?(?'type'[dscuobS%nfeEgGaACDiIOUpXx]{1})/m
str = 'Hello World! My name is %s and I have %+05.3f€'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end