import re
regex = re.compile(r"(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\+)[0-9]{2}:[0-9]{2}|)\[(\w+\/*\w*)]")
test_str = ("2015-08-30T16:00[America/Phoenix]\n"
"2015-08-30T16:00[America]\n"
"2015-08-30T16:00-07:00[America/Phoenix]\n"
"2015-08-30T16:00+07:00[America/Phoenix]\n"
"2015-08-30T16:00-07:00[America]\n"
"2015-08-30T16:00+07:00[America]\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")