using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div.*?>\s?(.*?)\s?<\/div>";
string input = @"<div class=""thumbnail label_c_hd"">HD</div>
<div class=""thumbnail label_c"">
1 / 3 FOR GROUP
</div>
<div>1 / 3 FOR GROUPS
</div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}