$re = '/<div.*?>\s?(.*?)\s?<\/div>/';
$str = '<div class="thumbnail label_c_hd">HD</div>
<div class="thumbnail label_c">
1 / 3 FOR GROUP
</div>
<div>1 / 3 FOR GROUPS
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);