package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div.*?>\s?(.*?)\s?<\/div>`)
var str = `<div class="thumbnail label_c_hd">HD</div>
<div class="thumbnail label_c">
1 / 3 FOR GROUP
</div>
<div>1 / 3 FOR GROUPS
</div>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}