import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div.*?>\\s?(.*?)\\s?<\\/div>";
final String string = "<div class=\"thumbnail label_c_hd\">HD</div>\n\n"
+ "<div class=\"thumbnail label_c\">\n"
+ "1 / 3 FOR GROUP\n"
+ "</div>\n\n"
+ "<div>1 / 3 FOR GROUPS\n"
+ "</div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}