#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?:\/\/)?(?:www\.)?(.*)\.(?=[\w.]{3,4})"
Local $sString = "http://www.example.com" & @CRLF & _
"http://www.example.co.uk" & @CRLF & _
"http://subdomain.example.com" & @CRLF & _
"http://subdomain.example.co.uk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")