re = /(?:https?:\/\/)?(?:www\.)?(.*)\.(?=[\w.]{3,4})/
str = 'http://www.example.com
http://www.example.co.uk
http://subdomain.example.com
http://subdomain.example.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end