using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/)?(?:www\.)?(.*)\.(?=[\w.]{3,4})";
string input = @"http://www.example.com
http://www.example.co.uk
http://subdomain.example.com
http://subdomain.example.co.uk";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}