$re = '/(?:https?:\/\/)?(?:www\.)?(.*)\.(?=[\w.]{3,4})/';
$str = 'http://www.example.com
http://www.example.co.uk
http://subdomain.example.com
http://subdomain.example.co.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);