using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\'?\w+([-']\w+)*\'?";
string input = @"Mary's, High-school, 'tis, Chambers', Qu'est-ce.
SHOULDN'T MATCH: ''tis, MARY'-'s";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}