$re = '/\'?\w+([-\']\w+)*\'?/m';
$str = 'Mary\'s, High-school, \'tis, Chambers\', Qu\'est-ce.
SHOULDN\'T MATCH: \'\'tis, MARY\'-\'s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);