package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\'?\w+([-']\w+)*\'?`)
var str = `Mary's, High-school, 'tis, Chambers', Qu'est-ce.
SHOULDN'T MATCH: ''tis, MARY'-'s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}