re = /\'?\w+([-']\w+)*\'?/m
str = 'Mary\'s, High-school, \'tis, Chambers\', Qu\'est-ce.
SHOULDN\'T MATCH: \'\'tis, MARY\'-\'s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end