#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<!--\s*(.*)\s*-->"
Local $sString = "<!-- Comment 1 -->" & @CRLF & _
"<!-- Comment 2 -->" & @CRLF & _
"<!-- Integer arcu tincidunt lorem odio dolor cum sit nec, risus, odio, placerat magna porta habitasse enim et sit. Dapibus enim! Cum! Et? Arcu, natoque mattis, lorem. Placerat, nec -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")