import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--\\s*(.*)\\s*-->";
final String string = "<!-- Comment 1 -->\n"
+ "<!-- Comment 2 -->\n"
+ "<!-- Integer arcu tincidunt lorem odio dolor cum sit nec, risus, odio, placerat magna porta habitasse enim et sit. Dapibus enim! Cum! Et? Arcu, natoque mattis, lorem. Placerat, nec -->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}