re = /<!--\s*(.*)\s*-->/m
str = '<!-- Comment 1 -->
<!-- Comment 2 -->
<!-- Integer arcu tincidunt lorem odio dolor cum sit nec, risus, odio, placerat magna porta habitasse enim et sit. Dapibus enim! Cum! Et? Arcu, natoque mattis, lorem. Placerat, nec -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end